Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Omg servo problem
#1
Hello everyone I just recently purchased a omg Lp-bf07S servo and I'm having trouble with it. When the front tires are on the ground the servo is not powerful enough to get full lock (only gets half). But when the tires are off the ground the servo proforms perfectly. What's wrong with it (setup up or is it the servo). Can only on help. ANY help is appreciated thanks guys!
Reply
#2
To start I would remove the linkage to the servo and make sure there was no binding in the front when turning the wheels by hand. They should turn lock to lock freely. Do this both with the wheels suspended and with them on the ground. Look for linkage binding someplace.
Gramps
---------------------------------------------------
MST RMX 2.0S 
MST FXX-D
Exceed RC MadPulse awd

Reply
#3
(09-10-2017, 08:48 PM)Gramps50 Wrote:  To start I would remove the linkage to the servo and make sure there was no binding in the front when turning the wheels by hand. They should turn lock to lock freely. Do this both with the wheels suspended and with them on the ground. Look for linkage binding someplace.

 Hey gramps I did what u said but there is still no binding in the steering its self. The servo is brand new. It seems like the servo does not have enough power to get full lock when the wheels are touching the ground. Thanks for the response hopefully I can resolve the steering issue.
Reply
#4
You didn't mention if it's RWD & AWD. If it's RWD and your using a gyro, which you should be, connect the servo directly to the rx and see if the problem still exist.

Check that your TX hasn't got a steering settings in the TX make sure they are all set to the default settings.
Gramps
---------------------------------------------------
MST RMX 2.0S 
MST FXX-D
Exceed RC MadPulse awd

Reply
#5
(09-13-2017, 07:29 PM)Gramps50 Wrote:  You didn't mention if it's RWD & AWD. If it's RWD and your using a gyro, which you should be, connect the servo directly to the rx and see if the problem still exist.

Check that your TX hasn't got a steering settings in the TX make sure they are all set to the default settings.

Hey gramps thanks for the help but I tryed it and it is the same with the gyro an with out. Is there any other suggestions because the servo is expensive so hopefully it's a mechanical issue. I know that with some things u need to break it in can it be that I need to do this
Reply
#6
When the car is off the servo goes farther then when it's on. Can ther be some sort of limiter maby?
Reply
#7
Try this, take servo linkage off from the steering. By hand push and tug the steering. Is it stiff ? Or difficult to push or pull ? This should be very very light to touch. There should not be any hard force to pull back from full lock to full lock.

If it is, the steering rack might be too tightly screwed on.

For servo turning range, it is dependent on the EPA and dual rate if you have it previously. Return everything to original. I know for me, I can set my EPA up to 150% left and right. But I normally leave it at 100%. If you do go for more then 100% listen for some servo buzzing. You will know the difference when you hear it.

The last thing , check your ball end screw and ball end joint. Are the matching? Are they too tight ?

Probably said the same thing as gramps. Can you show a photo of the linkages ?


Sent from my iPad using Tapatalk
Team Magic - E4D(4) RWD - Sakura D4 RWD
Reply
#8
It won't let me take a pic of the linkage but I checked the steering rack and it was the right looseness and can move freely. Is there any on there suggestions
Reply
#9
From your description I'm begining to think that you might have a bad servo. Do you have another servo you can try on the car or another car you can try the servo on?
Gramps
---------------------------------------------------
MST RMX 2.0S 
MST FXX-D
Exceed RC MadPulse awd

Reply
#10
Can you try this, recalibrate your esc. I know this has nothing to do with the servo, but you can try that.

I don't know what transmitter you have, if you can set the transmitter EPA for left and right to 120% gradually higher. See if that works.




Sent from my iPad using Tapatalk
Team Magic - E4D(4) RWD - Sakura D4 RWD
Reply
 


Forum Jump:


Users browsing this thread: 1 Guest(s)


About DriftMission.com - Your Home for RC Drifting

Your home for everything RC Drift! DriftMission.com offers RC Drift news, reviews, guides, chassis, videos, tips, countersteer tools, bodies, builds and more!

Serving up the latest RC Drift content since 2011.